Jump to content

Trouble with loading Fields Manager, if I insert data directly into _jreviews_fields via DB query.


Ant

Recommended Posts

Hi everyone.

Is there another table or something in JReviews that might cause trouble if I inserted fields directly into prefix_jreviews_fields ?

 

I'm developing on a virtual machine, so I tend to try stuff then revert to previous snapshots.

Today, I reverted to a fresh install of JReviews and tried to automate the population of JReviews fields by using the below SQL.

INSERT INTO database.prefix_jreviews_fields(fieldid, name, title, showtitle, description, required, groupid, type, location, options, size, maxlength, cols, rows, ordering, contentview, listview, compareview, listsort, search, access, access_view, published, metatitle, metakey, metadesc, control_field, control_value) VALUES
(1, 'jr_country', 'Country/Region', 1, '', 0, 1, 'select', 'content', '{"autocomplete":"1","click2search":"1","click2add":"1","description_position":"1","description_output":"0","autocomplete.search":"1","enable_sortable":"0","autocomplete.option_type":"link","autocomplete.option_pos":"after","option_images":"1","option_ordering":"1","click2searchlink":"tag\\/{fieldname}\\/{optionvalue}\\/?criteria={criteriaid}","output_format":"{FIELDTEXT}","click2search_format":"<a href=\\"{click2searchurl}\\">{optiontext}<\\/a>","formatbeforeclick":"0","php_format_theme":"","php_format":"","listing_type":""}', 0, 255, 0, 0, 1, 1, 0, 1, 0, 1, '1,2,3,4,5,6,7,8,9', '1,2,3,4,5,6,7,8,9', 1, '', '', '', '', ''),

but if I do it that way then go to Administrator ->JReviews ->Setup JReviews ->Fields Manager it refuses to load the relevant information. I can see that there is a server error, but when I check the logs there is no information there.

If I recreate the fields data manually, Administrator ->JReviews ->Setup JReviews ->Fields Manager works fine. The weird thing is though, if I then extract the data from the newly created data in prefix_jreviews_fields and use it to insert into a fresh install of JReviews, the same problem of Fields Manager not loading occurs, so I'm guessing there is some table in the DB that is clashing with the newly created data. Any ideas?

Link to post
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Please refer to our Privacy Policy.