Jump to content
Michael Pusch

Translation FILTERS_RANGE_MIN

Recommended Posts

Tried to translate following phrases from the default.po in my override folder but nothing happens. Cache was cleared.
Is there another position for this phrases?

msgid "FILTERS_RANGE_MIN"
msgstr "Min"

msgid "FILTERS_RANGE_MAX"
msgstr "Max"

msgid "FILTERS_RANGE_DELIMITER"
msgstr "bis"

Share this post


Link to post

I deleted all possible caches and nothing changed. Today in the morning again.

For testing I changed the core default.po file in component folder with the same result. No translation in advanced filter module.

Share this post


Link to post

You are right, it doesn't work. I spent a lot of time trying to figure out why without success. So I will add to the list of things to check for the next update so I can dedicate as much time as needed.  For now, even though not ideal, you can make the change in the "eng" locale in the core.

Share this post


Link to post

I came back to this and after going line by line in the code to figure out where it was breaking I realized there was nothing wrong. .There's something very odd going on here because I copied the strings from your post and those don't work. However, after deleting it and manually writing the whole thing instead of copy/paste, it actually worked. And the weird thing is that even if I changed the msgid to something else, but using the pasted string, it also didn't work. So please try that again. Remove the msgid and msgstr. Then write it manually and clear the registry. 

Share this post


Link to post

I can imagine it. It could be something to do with a wrong keyboard layout for ", and if it is wrong one time, everybody is copying the same error. It's like a virus. 🙂

But it is only a presumption from me. I don't know the real reason. But now it's working fine.

Share this post


Link to post

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Please refer to our Privacy Policy.