Jump to content


Photo

cant upload audio ; invalid extension


Best Answer Alejandro , 07 February 2018 - 01:25 PM

In the upload form do you see that audio icon indicating the form allows this type of file to be uploaded? If you have Amazon S3 selected as the storage for audio, then you also need to configure media encoding. Otherwise, for local uploads it's not necessary, but you need to change it in the Media Settings / Storage tab. Just be aware that not all audio formats are compatible with all browsers when you use local storage.

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 ededi

ededi

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 06 February 2018 - 04:14 PM

by the way its joomla not wordpress sorry for fault category

 

i get this error when try uploading a audio after submit listing

 

xxxxxxx.MP3 has an invalid extension. Allowed extensions: jpg, jpeg, gif, png.


Edited by ededi, 06 February 2018 - 04:16 PM.


#2 Alejandro

Alejandro

    Advanced Member

  • Administrators
  • 32291 posts

Posted 06 February 2018 - 05:46 PM

Did you try with ".mp3" instead of ".MP3"?

 

Try adding uppercase extensions for each media type in the Media Settings to see if that makes a difference.



#3 ededi

ededi

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 07 February 2018 - 11:26 AM

Did you try with ".mp3" instead of ".MP3"?

 

Try adding uppercase extensions for each media type in the Media Settings to see if that makes a difference.

The Tears Of Autumn.mp3 has an invalid extension. Allowed extensions: jpg, jpeg, gif, png.

 

In options of audio i hv like this ; m4a,mp3,pcm,aac,oga,webm,MP3,M4A

 

it cant read correct which file type is allowed



#4 Alejandro

Alejandro

    Advanced Member

  • Administrators
  • 32291 posts

Posted 07 February 2018 - 01:25 PM   Best Answer

In the upload form do you see that audio icon indicating the form allows this type of file to be uploaded? If you have Amazon S3 selected as the storage for audio, then you also need to configure media encoding. Otherwise, for local uploads it's not necessary, but you need to change it in the Media Settings / Storage tab. Just be aware that not all audio formats are compatible with all browsers when you use local storage.



#5 ededi

ededi

    Advanced Member

  • Members
  • PipPipPip
  • 131 posts

Posted 07 February 2018 - 03:36 PM

In the upload form do you see that audio icon indicating the form allows this type of file to be uploaded? If you have Amazon S3 selected as the storage for audio, then you also need to configure media encoding. Otherwise, for local uploads it's not necessary, but you need to change it in the Media Settings / Storage tab. Just be aware that not all audio formats are compatible with all browsers when you use local storage.

 

ok i can now upload audio , it was in access settings like youtube link but also this option doesnt show in detail page after publishing now i get a blank page when click on link

 

i sent a ticket for this and youtube problem






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users