Jump to content


Photo

clean install on localhost of joomla 2.5.0 and jreviews


  • Please log in to reply
4 replies to this topic

#1 rob morphet

rob morphet

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 27 January 2012 - 04:44 PM

HI, really like the jreviews and desperate to get this working on trial so I can buy the real deal. (been burnt with WPMU-Dev stuff before) so want to see this working first!
I am not a dev guy, just regular joe, so please be cool and easy with me!

Install the XAMPP tool, and config all okay, great.
Clean install the Joomla 2.5.0 pack
Install the ioncube tool, alls good. Have curl etc
install the Jreviews as per the walk though, and get confirmation the com_s2framework_1.4.zip has loaded great.
install the second pack, com_jreviews_2.3.zip, and alls good, get 3 success posts.
click on article and get the following error:

Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\Joomla\components\com_jreviews\jreviews\includes\plugins\jreviews.php on line 43
The S2 Framework required to run jReviews is not installed. Please install the com_s2framework component included in the jReviews package.


This is the 4th time I have tried, and I have even un-installed everything, deleted the folders and tried again.
Please, any ideas, searching google wont turn anything up either.

your, desperate! :-[

Rob


#2 Alejandro

Alejandro

    Advanced Member

  • Administrators
  • 28589 posts

Posted 27 January 2012 - 05:07 PM

Disable DEVELOPMENT error reporting in Joomla configuration.

#3 rob morphet

rob morphet

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 28 January 2012 - 01:47 AM

Thanks Alejandro
so I followed the install and selected site/global config/system/Debug Settings/Debug System/[No]
and have selected site/global config/server/Error Reporting/[none]

re-started both pc and xampp and still get the S2 error when trying to add a new article still (have imported test data from joomla okay).

http://localhost/joo...cle&layout=edit
gives
The S2 Framework required to run jReviews is not installed. Please install the com_s2framework component included in the jReviews package.

Would it be easier if I installed online?

I want this to work as I have loved the demo's I have seen

#4 Kristian

Kristian

    Advanced Member

  • Moderators
  • 12524 posts

Posted 28 January 2012 - 06:11 AM

http://localhost/joo...cle&layout=edit
gives
The S2 Framework required to run jReviews is not installed. Please install the com_s2framework component included in the jReviews package.


From your first post it wasn't clear that you were editing the article in Article Manager in administration.
Here is a patch for this problem:
http://www.reviewsfo...p?topic=18621.0

#5 rob morphet

rob morphet

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 January 2012 - 02:25 PM

Hi, had tried that, loading in to plugins/content/jreviews without success.

I have just removed and re-loaded everything Inc Xmapp and ioncube) again and now its working, maybe a fresh set of eyes and confidence I was doing the right process has helped.

really appreciate your support guys, thank you





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users